glib-2.12 gthread-2.0 is required to compile QEMU

I was building under the vperf project of OPNFV and I saw the following error in the output:

ERROR: glib-2.12 gthread-2.0 is required to compile QEMU

My server is running CentOS 7. After much searching and finding several incorrect answers, I found this one that solved my problem:

http://stackoverflow.com/questions/22836219/centos-6-5-howto-install-gtk-version-2-8-0

The summary:

sudo yum install gtk2-devel

Now my build has succeeded!

Advertisements